Problem:
I am getting the error "Invalid Redirect - Attempted to redirect to an offsite host." when navigating around my Deskpro installation. It happens when I log in.
Cause:
Deskpro does not allow any redirections offsite (to other servers or URLs) for security reasons. This does not apply if you click on an external hyperlink embedded into the helpdesk such as a link in a ticket response - as this means you have actively followed a link offsite. This will kick if in any script or function attempts to send you to another server.
One potential cause of this is if your main URL is not configured correctly:
https://support.deskpro.com/en_GB/guides/sysadmin-guide/configuring-on-premise/domain-setup
If you are using a local alias such as "helpdesk" in the above example, but have your public FQDN or any other domain configured in your settings, Deskpro will be trying to direct you to your chosen domain name, and you will run into this error.
Resolution:
If you must have mismatching URL settings (not recommended), you can refresh your browser past this page in some cases.
To fix this warning permanently, you can visit Admin > Setup > Settings and ensure the configured helpdesk URL is always the one you use to actually browse the helpdesk.
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