Fatal Swift.php error

Question:

I moved my Deskpro installation to a new server and I'm getting this error:

Fatal error: Cannot call overloaded function for non-object in /var/www/html/app/vendor/swiftmailer/swiftmailer/lib/classes/Swift.php on line 62

How can I fix this?

Answer:

This problem can happen if you have the Alternative PHP Cache (APC) PHP accelerator installed.

APC is only required for older versions of PHP. Current versions of Deskpro require PHP 5.5+, which includes the Zend Opcache accelerator. If you encounter this problem, we recommend you disable APC (the method will vary depending on your platform), and update PHP to 5.5 or above.

Helpful Unhelpful

8 of 22 people found this page helpful

Add a comment

You need to log in before you can submit a comment.

Need a password reminder?